Emtac S3 Mini Bluetooth GPS Receiver – 支援論壇

BT connection with Windows Vista? [Emtac S3 Mini Bluetooth GPS Receiver - 143017]

  • PelleO
  • 投稿: 6
  • 註冊日期: 15 一月 2008

Hi,

 

I have today got my Emtac S3 Mini BT-GPS and try to connect it to my laptop with Vista. Vista finds the S3 but it couldnt connect in any prog as it complains of COM-port failure. I try the CruxView test program and it is the same error.

Anyone have tried a similar setup?

 Is the S3 Mini really compatible with Vista?

I have connected the S3 succesful to my SonyEricsson phone with BT so it is nothing wrong with it as I can understand.

 

  • PeteGraham
  • 投稿: 20786
  • 註冊日期: 3 三月 2004

It should be fine with Vista, as it's only using serial port.  The problem I imagine lies within your bluetooth dongle itself, or the stack provided by the bluetooth dongle manufacturer.  Do you know if you have any incoming/outgoing com ports created on your laptop in the bluetooth settings?  Which service does the S3 show that it provides and uses?

Pete (I need JD) Graham ************** Damn you! Use forum search!!.

  • PelleO
  • 投稿: 6
  • 註冊日期: 15 一月 2008
It connects for very short times randomly and has allocated COM10 (out) and COM11 (in). What do you mean with services in this case?
  • PeteGraham
  • 投稿: 20786
  • 註冊日期: 3 三月 2004

Apologies.  When you connect something via bluetooth it should tell you what services it supports - for example Bluetooth SPP (Serial Port replacement Profile) amongst other things.

If you bring up the properties of the Emtac device when it's connected it should have a tab for services, however it would appear to be SPP, given your statement about 10 and 11.

What brand of bluetooth dongle are you using and which bluetooth stack are you running?  It could be bluesoleil, or Microsoft, or something like that.

Pete (I need JD) Graham ************** Damn you! Use forum search!!.

  • PelleO
  • 投稿: 6
  • 註冊日期: 15 一月 2008

Thanks for trying to help me!

This is the information concerning Bluetooth on my laptop:

HP Pavilion dv 9380ea (Laptop)

Bluetooth-radio

-          HP Integrated Bluetooth

o   HCI version 3.8489. LMP version 3.16847

-          Microsoft Bluetooth Enumerator

o   Microsoft Corporation

o   6.0.600.16386 (vista_rtm.061101-2205)

Services

-          Seriell port (SPP) Bluetooth Serial Port COM10 

Software running in Vista (tray):

BTTray.exe

Bluetooth Software 6.0.1.3100

Broadcom Corporation.

 

  • PeteGraham
  • 投稿: 20786
  • 註冊日期: 3 三月 2004

You have a broadcom stack on this machine.  I use broadcom stacks elswhere and have always found them to be brilliant.  If you connect the bluetooth device to your laptop and don't run any other programs, does it perform ok or does it just drop out the connection?

Pete (I need JD) Graham ************** Damn you! Use forum search!!.

  • PelleO
  • 投稿: 6
  • 註冊日期: 15 一月 2008

When I open and watch the BT-devices prog I have two devices installed my phone and the BT-GPS.

Under the Emtac device it state:

"Key activated" (translated from Swedish since I use a Swedish Vista version)

And sometimes randomly it flashes:

"Connected"

But only for a couple of seconds and if I open the device window it changes the "Last connected den 17 januari 2008 kl 16:17:50". This shows that it has some connection but only very short and the blue light on the Emtac never change to connect mode.

Maybe I should try with some other BT devices to see if it works with them, for example a BT-mouse I have.

  • PelleO
  • 投稿: 6
  • 註冊日期: 15 一月 2008

I now tried with a BT-mouse and it works excellent!

Very difficult this!

  • PelleO
  • 投稿: 6
  • 註冊日期: 15 一月 2008

Still same problem! This isnt working!

 

;